Fedora 11 woes

1242888547000 » Tagged as: lame , video

Like with Fedora 10 playing videos is not easy on Fedora 11 either. VLC player simply will not start.

VLC media player 1.0.0-rc1 Goldeneye Bus error Tried to do a yum update hoping that this is a bug that has been fixed.

Loaded plugins: refresh-packagekit Setting up Update Process Resolving Dependencies --> Running transaction check ---> Package rpmfusion-free-release.noarch 0:11-1 set to be updated ---> Package x264.x86_64 0:0.65-9_20090117.2245.fc10_92 set to be updated --> Processing Dependency: libx264.so.67()(64bit) for package: vlc-core --> Finished Dependency Resolution vlc-core-1.0.0-0.5rc1.fc11.x86_64 from installed has depsolving problems --> Missing Dependency: libx264.so.67()(64bit) is needed by package vlc-core-1.0.0-0.5rc1.fc11.x86_64 (installed) Error: Missing Dependency: libx264.so.67()(64bit) is needed by package vlc-core-1.0.0-0.5rc1.fc11.x86_64 (installed) You could try using --skip-broken to work around the problem You could try running: package-cleanup --problems package-cleanup --dupes rpm -Va --nofiles --nodigest At the end of the error message it provides some suggestions unfortunately none of them worked. I did a yum whatprovides to find out what the missing RPM might be. There are several possible candidates and most of them appear to be for Fedora 10. I picked one almost by random and tried to install it and got the exact same error produced above. Hello! The very reason I am trying to install this RPM because the shared object is not there so don't tell me that it's not there! I tried removing VLC and trying to put it back in again. That resulted in the above yum error going away, but it failed to make the vlc error go away. Then I found the installed 264 libraries and yum removed them yum remove x264-libs-0.0.0-0.24.20090319gitc109c8.fc11.x86_64 libx264_65-0.65-9_20090117.2245.fc10_92.x86_64 There were  a lot of dependencies and nearly all of them were F10 rpms. These were also removed by yum. Then I re installed vlc one more time. This time a lot of dependencies were installed which had the .f11 tag in their filenames. The installation wasn't successful.

Transaction Check Error: file /usr/lib64/libfaad.so.2.0.0 from install of faad2-libs-1:2.7-1.fc11.x86_64 conflicts with file from package libfaad2-1:2.7-16.fc10_92.x86_64 file /usr/lib64/libavutil.so.49.15.0 from install of ffmpeg-libs-0.5-2.fc11.x86_64 conflicts with file from package libavutil49-0.5-30.fc10_92.x86_64 file /usr/lib64/libswscale.so.0.7.1 from install of ffmpeg-libs-0.5-2.fc11.x86_64 conflicts with file from package libswscale0-0.5-30.fc10_92.x86_64 file /usr/lib64/libpostproc.so.51.2.0 from install of ffmpeg-libs-0.5-2.fc11.x86_64 conflicts with file from package libpostproc51-0.5-30.fc10_92.x86_64

Error Summary

Removed these offending RPMs and trying installing VLC one more time. The installation was successful but vlc still refuses to start. Time to give up on this.
comments powered by Disqus